HTC Sense 3.0 ONLY for Newer Devices?

This is sad news. Remember HTC Sensation that has HTC Sense 3.0? Now, it seems that HTC has confirmed (via Twitter) that they are NOT bringing HTC Sense 3.0 to older devices.

From the Twitter post, HTC mentions only the recent devices like HTC Sensation, HTC EVO 3D, HTC Flyer will get HTC Sense 3.0

The reason seems to be simply the hardware requirement for HTC Sense 3.0. So, lets hope XDA can do something about it when it is released 🙂 .

[ad#boxlist]
(source)

 

READ  Unnamed New HTC Android Phone Spied with Pictures